打开APP
userphoto
未登录

开通VIP,畅享免费电子书等14项超值服

开通VIP
PAT A1154 Vertex Coloring (25 分)

A proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10^4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

实现思路:

感觉以前的pat题目真的简单很多,比起leetcode一般都只要题目读懂意思了,就不会太难了,本题是一道图论题目,要求图中每一对相邻顶点的颜色都不相同,如果相同就输出no,反之就统计不同的颜色数,只需要用邻接表存储图,然后双重循环遍历,判断即可。

AC代码:

#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;
const int N=10010;
vector<int> G[N];
int n,m,a,b,k,num,colNum;
bool vist[N];
vector<int> color;

bool judge() {
	for(int i=0; i<n; i++) {
		for(int j=0; j<G[i].size(); j++) {
			if(color[i]==color[G[i][j]]) return false;//如果相邻结点颜色相同则返回no
		}
	}
	return true;
}

int main() {
	cin>>n>>m;
	while(m--) {
		scanf("%d%d",&a,&b);
		G[a].push_back(b);
		G[b].push_back(a);
	}
	cin>>k;
	while(k--) {
		colNum=0;
		color.clear();
		color.resize(n);
		unordered_map<int,int> mp;
		for(int i=0; i<n; i++) scanf("%d",&color[i]);
		for(int i=0; i<n; i++) mp[color[i]]=1;
		if(judge()) printf("%d-coloring",mp.size());
		else printf("No");
		printf("\n");
	}
	return 0;
}
本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报
打开APP,阅读全文并永久保存 查看更多类似文章
猜你喜欢
类似文章
【热】打开小程序,算一算2024你的财运
GPU编程--hlsl--04--基础纹理混合
unity 溶解贴花编辑器
<Unity3D>Unity3D中MeshRenderer的使用
高级着色语言HLSL入门(1)
0593. Valid Square (M)
从零开始学习OpenGL ES之四 – 光效
更多类似文章 >>
生活服务
热点新闻
分享 收藏 导长图 关注 下载文章
绑定账号成功
后续可登录账号畅享VIP特权!
如果VIP功能使用有故障,
可点击这里联系客服!

联系客服