打开APP
userphoto
未登录

开通VIP,畅享免费电子书等14项超值服

开通VIP
【Experimental archive】Manually Summarizing EIGRP
网友:lcq2202008 发布于: 2008.05.31 11:29 (共有条评论) 查看评论 | 我要评论
Manually  Summarizing EIGRP Routes
实验目的:
1、理解EIGRP的自动汇聚的缺点
2、掌握EIGRP的手工自动汇总的配置方法
实验TOP:
实验步骤及要求:
1、配置各台路由器的IP地址,并且能互相ping通。
R1#sh run
Building configuration...
00:17:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 10.1.0.1 255.255.255.0
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.252
duplex auto
speed auto
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
no scheduler allocate
end
.......................................................................
R2#sh
00:15:36: %SYS-5-CONFIG_I: Configured from console by consolerun
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet1/0
ip address 172.16.1.2 255.255.255.252
!
interface Ethernet1/1
ip address 172.16.1.5 255.255.255.252
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
no scheduler allocate
end
........................................................................................
R3#sh run
00:11:05: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
ip address 192.168.2.1 255.255.255.0
!
interface Loopback3
ip address 192.168.3.1 255.255.255.0
!
interface Ethernet1/0
ip address 172.16.1.6 255.255.255.252
!
interface Ethernet1/1
ip address 172.16.1.9 255.255.255.252
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
no scheduler allocate
end
........................................................................................
R4#sh
00:08:33: %SYS-5-CONFIG_I: Configured from console by consolerun
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 10.1.16.1 255.255.255.0
!
interface Loopback1
ip address 10.1.17.1 255.255.255.0
!
interface Loopback2
ip address 10.1.18.1 255.255.255.0
!
interface Loopback3
ip address 10.1.19.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.1.10 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
no scheduler allocate
end
2、配置各路由器的EIGRP协议,并且不关闭自动汇总 (下以R4为例)
R4(config)#router eigrp 50
R4(config-router)#network 172.16.0.0
R4(config-router)#network 10.1.0.0
R4(config-router)#ex
R4(config)#
3、查看各路由器上的路由表,验证EIGRP协议的配置情况。(以R4位例)
R4#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C       172.16.1.8/30 is directly connected, FastEthernet0/0
D       172.16.1.4/30 [90/284160] via 172.16.1.9, 00:02:00, FastEthernet0/0
D       172.16.0.0/16 is a summary, 00:02:51, Null0
D       172.16.1.0/30 [90/309760] via 172.16.1.9, 00:01:44, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D       10.0.0.0/8 is a summary, 00:02:43, Null0
C       10.1.19.0/24 is directly connected, Loopback3
C       10.1.18.0/24 is directly connected, Loopback2
C       10.1.17.0/24 is directly connected, Loopback1
C       10.1.16.0/24 is directly connected, Loopback0
D    192.168.0.0/24 [90/156160] via 172.16.1.9, 00:02:00, FastEthernet0/0
4、在R2上使用ping测试网络路由,会发现R2无法ping通R4所连接的10.1.X.0/24网络子网。
R2#ping 10.1.17.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.17.1, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)
R2#ping 10.1.19.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.19.1, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)
但能ping通R1上的子网。
R2#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/62/117 ms
5、查看R2路由表,查找原因。
R2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/30 is subnetted, 3 subnets
D       172.16.1.8 [90/307200] via 172.16.1.6, 00:13:50, Ethernet1/1
C       172.16.1.4 is directly connected, Ethernet1/1
C       172.16.1.0 is directly connected, Ethernet1/0
D    10.0.0.0/8 [90/409600] via 172.16.1.1, 00:12:56, Ethernet1/0  //这是关于10.1.X.0/24的路由汇总//
D    192.168.0.0/24 [90/409600] via 172.16.1.6, 00:13:50, Ethernet1/1
R2#sh ip eigrp top
R2#sh ip eigrp topology all-l
R2#sh ip eigrp topology all-links
IP-EIGRP Topology Table for AS(50)/ID(172.16.1.5)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status
P 10.0.0.0/8, 1 successors, FD is 409600, serno 6
via 172.16.1.1 (409600/128256), Ethernet1/0
via 172.16.1.6 (435200/409600), Ethernet1/1 //可以看出10.0.0.0/8有两条路由,注意到这两条路由的FD值是不相同的,而且
via 172.16.1.1 (409600/128256) 比172.16.1.6 (435200/409600)小//
P 192.168.0.0/24, 1 successors, FD is 409600, serno 4
via 172.16.1.6 (409600/128256), Ethernet1/1
P 172.16.1.8/30, 1 successors, FD is 307200, serno 3
via 172.16.1.6 (307200/281600), Ethernet1/1
P 172.16.1.4/30, 1 successors, FD is 281600, serno 2
via Connected, Ethernet1/1
P 172.16.1.0/30, 1 successors, FD is 281600, serno 1
via Connected, Ethernet1/0
7、导致R2无法ping通R4所连接的10.1.X.0/24子网的主要原因是:R1本身属于主类的边界,其会将本地路由表中的子网向主类网络自动汇集。
R4也和R1的情况一样,也会做出相同的动作。这样R2将会从不同的接口收到相同的路由汇总,即10.0.0.0/8两条网络路由。由于R2在比较两条
路由的可行距离后,选择了FD值较小的那条路由,即R1通告的10.0.0.0/8路由。其实真正的原因,并不是路由选择出错,而是自动汇聚不能做
到精确的控制原因导致的。
8、为了解决问题,需要在R1和R4上关闭自动汇总,而采用手工汇总。配置如下:
R1#conf t
R1(config)#
R1(config)#router eigrp 50
R1(config-router)#no auto-summary
R1(config-router)#ex
R1(config)#
R1(config)#int fastEthernet 0/1
R1(config-if)#ip summary-add
R1(config-if)#ip summary-address eigrp 50 10.1.0.0 255.255.252.0
R1(config-if)#ex
R1(config)#
R1(config)#^Z
R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#
R4(config)#router eigrp 50
R4(config-router)#
R4(config-router)#no aut
R4(config-router)#no auto-summary
R4(config-router)#ex
R4(config)#
R4(config)#int fa
R4(config)#int fastEthernet 0/0
R4(config-if)#
R4(config-if)#ip summary-address eigrp 50 10.1.16.0 255.255.252.0
R4(config-if)#ex
R4(config)#^
9、再次查看R2路由表
R2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/30 is subnetted, 3 subnets
D       172.16.1.8 [90/307200] via 172.16.1.6, 00:43:22, Ethernet1/1
C       172.16.1.4 is directly connected, Ethernet1/1
C       172.16.1.0 is directly connected, Ethernet1/0
10.0.0.0/22 is subnetted, 2 subnets
D       10.1.0.0 [90/409600] via 172.16.1.1, 00:04:31, Ethernet1/0  //被汇总的/22位的网络路由//
D       10.1.16.0 [90/435200] via 172.16.1.6, 00:02:10, Ethernet1/1
D    192.168.0.0/24 [90/409600] via 172.16.1.6, 00:43:22, Ethernet1/1
10、再次使用ping命令确认网络可达性
R2#ping 10.1.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/67/76 ms
R2#
R2#
R2#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/45/53 ms
R2#ping 10.1.16.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.16.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 144/167/212 ms
R2#
R2#
R2#ping 10.1.19.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.19.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/133/188 ms
R2#
11、通过本实验可以看出,虽然EIGRP的自动汇总能够为网络配置带来便捷,但是其依赖于 IP子网的规划。如果遇到糟糕的子网规划,则需要
小心使用自动特性。
12、实验最终的配置
R1#sh run
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 10.1.0.1 255.255.255.0
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.252
ip summary-address eigrp 50 10.1.0.0 255.255.252.0 5
duplex auto
speed auto
!
router eigrp 50
network 10.0.0.0
network 172.16.0.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
end
............................................................................................
R2#sh run
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet1/0
ip address 172.16.1.2 255.255.255.252
!
interface Ethernet1/1
ip address 172.16.1.5 255.255.255.252
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
router eigrp 50
network 172.16.0.0
no eigrp log-neighbor-changes
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
end
........................................................................................
R3#sh r
01:28:14: %SYS-5-CONFIG_I: Configured from console by consoleun
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
ip address 192.168.2.1 255.255.255.0
!
interface Loopback3
ip address 192.168.3.1 255.255.255.0
!
interface Ethernet1/0
ip address 172.16.1.6 255.255.255.252
!
interface Ethernet1/1
ip address 172.16.1.9 255.255.255.252
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
router eigrp 50
network 172.16.0.0
network 192.168.0.0
network 192.168.1.0
no eigrp log-neighbor-changes
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
end
..............................................................................................
R4#sh run
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 10.1.16.1 255.255.255.0
!
interface Loopback1
ip address 10.1.17.1 255.255.255.0
!
interface Loopback2
ip address 10.1.18.1 255.255.255.0
!
interface Loopback3
ip address 10.1.19.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.1.10 255.255.255.252
ip summary-address eigrp 50 10.1.16.0 255.255.252.0 5
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 50
network 10.0.0.0
network 172.16.0.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
end
13、实验完成
本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报
打开APP,阅读全文并永久保存 查看更多类似文章
猜你喜欢
类似文章
【热】打开小程序,算一算2024你的财运
动态路由协议:RIP、OSPF、EIGRP简介
CCIE学习(34)—— EIGRP配置
[原创] ipsec高可用性试验
两个大学之间的2621配置(转贴)
谁说限网速一定要用行为管理器?用交换机也能限速,操作也简单
【干货】大神教你如何OSPF配置?
更多类似文章 >>
生活服务
热点新闻
分享 收藏 导长图 关注 下载文章
绑定账号成功
后续可登录账号畅享VIP特权!
如果VIP功能使用有故障,
可点击这里联系客服!

联系客服